For additional help, visit pieces.app/support or contact our team directly.
Resolved
This issue has been marked as monitoring & resolved.
Investigating
What you may experience:
Unable to view or update billing information
Subscription changes and plan upgrades may not process
Payment method updates unavailable
What still works:
All Pieces features continue to work normally
Your current subscription remains active
Our team is actively investigating and will provide updates as more information becomes available.