For additional help, visit pieces.app/support or contact our team directly.
Google Gemini has reported that all systems are operational. AI features powered by Google Gemini — including Pieces Conversational Search and single-click summaries — should now be functioning normally.
If you continue to experience issues, please contact support.
Resolved
Google Gemini has reported that all systems are operational. AI features powered by Google Gemini — including Pieces Conversational Search and single-click summaries — should now be functioning normally.
If you continue to experience issues, please contact support.
Identified
Google Gemini is experiencing issues that may impact your Pieces experience.
What you may experience:
Pieces Conversational Search responses may fail or time out when using affected models
Single-click summaries may be unavailable
Affected models: Gemini 3.1 Pro Preview, Gemini 3 Flash Preview, Gemini 2.5 Pro, and 5 other models
Workaround: You can switch to OpenAI (GPT-5.4, etc.), Anthropic (Claude 4.6 Opus, etc.), AWS Bedrock (Amazon Nova Pro, etc.) in your Pieces model settings. On-device (local) models also remain fully operational.
We are monitoring the situation and will provide updates as more information becomes available.
Track this issue: Google Gemini Status Page