For additional help, visit pieces.app/support or contact our team directly.
Pieces Enterprise Portal is now fully operational. All affected features have been restored and are working normally.
If you continue to experience issues, please contact support.
Resolved
Pieces Enterprise Portal is now fully operational. All affected features have been restored and are working normally.
If you continue to experience issues, please contact support.
Investigating
We continue to investigate issues affecting billing and subscription management unavailable.
Current status: Some Portal Services Degraded
What you may experience:
Unable to view or update billing information
Subscription changes and plan upgrades may not process
Payment method updates unavailable
We will provide further updates as the situation develops.
Investigating
We continue to investigate issues affecting pieces portal unavailable.
Current status: Portal Partially Unavailable
What you may experience:
Unable to access the Pieces Portal
Organization management and team settings unavailable
We will provide further updates as the situation develops.
Investigating
What you may experience:
Unable to view or update billing information
Subscription changes and plan upgrades may not process
Payment method updates unavailable
Our team is actively investigating and will provide updates as more information becomes available.